EPCS System Requirements

System Requirements for drchrono EPCS

Prior to using the drchrono EHR to prescribe controlled substances (EPCS), you are required to meet all the drchrono system requirements while additionally certifying that you will keep your system up to date with the latest security patches. Certain mobile devices are following requirements:
 
1. On your personal computer, you certify that the operating system used is supported by drchrono and must be kept up to date with the latest security patches. The drchrono EHR supports the following operating systems:
  • Windows: Windows 7 or above
  • Macintosh: OS X 10.10 or above
2. The web browser used to access drchrono must be a supported browser that is kept up to date with the latest security patches. The drchrono EHR supports the following web browsers:
  • Google Chrome
  • Apple Safari
  • Mozilla Firefox
 
3. You must use a mobile device compatible and installed with the Symantec VIP Access mobile application. You may find the mobile application and the list of compatible devices on the Symantec Validation & ID Protection Mobile Center found here
 
4. If you are using drchrono on a mobile platform (iPhone, iPad, etc), you certify that your device's operating system and the drchrono mobile application is to be consistently kept up to date with the latest security patches and updates.
Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk